Looking for a bit of assistance on this as I am struggling to get the routing to work.
I have a ERX-SFP with a few different networks. One network is configured into eth1 for DMZ/IOT devices, while the rest are configured in Switch0. The default network is switch0 10.20.255.1/24 with 3 different vlans created. One for production network(vlan 66), one for guest wifi(vlan 200) and the other I just created for the wifi VPN(vlan 94).
Basically what I am trying to do is forward all traffic on the wifi_VPN group over the wireless. I am able to get the tunnel up, I am seeing the NAT masquerade get hits but it doesn't seem to get any traffic to go over the tunnel. If I had to guess it has to do with the route.
here is the configuration I did for the VPN. I think my problem is the set interfaces but I am not sure.
set interfaces openvpn vtun0 config-file /config/auth/my_expressvpn_australia_-_brisbane_udp.ovpn
set interfaces openvpn vtun0 description 'ExpressVPN'
set service nat rule 5000 description ExpressVPN
set service nat rule 5000 log disable
set service nat rule 5000 outbound-interface vtun0
set service nat rule 5000 source address 10.94.66.0/24
set service nat rule 5000 type masquerade
set service nat rule 5001 description default
set service nat rule 5001 log disable
set service nat rule 5001 outbound-interface eth0
set service nat rule 5001 source address 10.94.66.0/24
set service nat rule 5001 type masquerade
set protocols static table 1 interface-route 0.0.0.0/0 next-hop-interface vtun0
set firewall modify express_vpn_route rule 10 description 'ExpressVPN'
set firewall modify express_vpn_route rule 10 source address 10.94.66.0/24
set firewall modify express_vpn_route rule 10 modify table 1
set interfaces vti 94 firewall in modify modify express_vpn_route
(also tried as set interfaces switch switch0 firewall in modify express_vpn_route with no luck)
Below is my config minus what you see above. I have reverted to a prior config to make sure anything I did incorrect is not there.
firewall {
all-ping enable
broadcast-ping disable
ipv6-receive-redirects disable
ipv6-src-route disable
ip-src-route disable
log-martians enable
name DMZ_Local {
default-action drop
description ""
rule 1 {
action accept
description "Allow DHCP"
destination {
port 67
}
log disable
protocol udp
}
rule 2 {
action accept
description "Allow DNS"
destination {
port 53
}
log disable
protocol udp
}
}
name Guest_Local {
default-action drop
description ""
rule 1 {
action accept
description "Allow DHCP"
destination {
port 67
}
log disable
protocol udp
}
rule 2 {
action accept
description "Allow DNS"
destination {
port 53
}
log disable
protocol udp
}
}
name PROD_IN {
default-action drop
description ""
}
name PROD_OUT {
default-action drop
description ""
}
name WAN_IN {
default-action drop
description "WAN to internal"
rule 10 {
action accept
description "Allow established/related"
state {
established enable
related enable
}
}
rule 20 {
action drop
description "Drop invalid state"
state {
invalid enable
}
}
}
name WAN_LOCAL {
default-action drop
description "WAN to router"
rule 10 {
action accept
description "Allow established/related"
state {
established enable
related enable
}
}
rule 20 {
action drop
description "Drop invalid state"
state {
invalid enable
}
}
}
receive-redirects disable
send-redirects enable
source-validation disable
syn-cookies enable
}
interfaces {
ethernet eth0 {
address dhcp
description Internet
duplex auto
firewall {
in {
name WAN_IN
}
local {
name WAN_LOCAL
}
}
speed auto
}
ethernet eth1 {
address 192.168.1.1/24
description DMZ_IOT
duplex auto
firewall {
in {
}
local {
name DMZ_Local
}
}
poe {
output off
}
speed auto
}
ethernet eth2 {
description Local
duplex auto
poe {
output 24v
}
speed auto
}
ethernet eth3 {
description Local
duplex auto
speed auto
}
ethernet eth4 {
description Local
duplex auto
speed auto
}
ethernet eth5 {
duplex auto
speed auto
}
loopback lo {
}
switch switch0 {
address 10.20.255.1/24
description Local
mtu 1500
switch-port {
interface eth2 {
}
interface eth3 {
}
interface eth4 {
}
vlan-aware disable
}
vif 66 {
address 10.66.94.1/24
description Prod_Home
mtu 1500
}
vif 200 {
address 172.16.200.1/24
description Guest_Wifi
firewall {
local {
name Guest_Local
}
}
mtu 1500
}
}
}
service {
dhcp-server {
disabled false
hostfile-update disable
shared-network-name Guest_Wifi {
authoritative disable
subnet 172.16.200.0/24 {
default-router 172.16.200.1
dns-server 8.8.8.8
dns-server 8.8.4.4
lease 86400
start 172.16.200.100 {
stop 172.16.200.120
}
}
}
shared-network-name LAN1 {
authoritative enable
subnet 192.168.1.0/24 {
default-router 192.168.1.1
dns-server 192.168.1.1
lease 86400
start 192.168.1.38 {
stop 192.168.1.243
}
}
}
shared-network-name LAN2 {
authoritative enable
subnet 10.20.255.0/24 {
default-router 10.20.255.1
dns-server 10.20.255.1
lease 86400
start 10.20.255.38 {
stop 10.20.255.243
}
unifi-controller 10.66.94.252
}
}
shared-network-name Prod_Home {
authoritative disable
subnet 10.66.94.0/24 {
default-router 10.66.94.1
dns-server 10.66.94.252
lease 86400
start 10.66.94.10 {
stop 10.66.94.200
}
unifi-controller 10.66.94.252
}
}
shared-network-name VPN_Wifi {
authoritative disable
subnet 10.94.66.0/24 {
default-router 10.94.66.1
dns-server 1.1.1.1
dns-server 1.0.0.1
lease 86400
start 10.94.66.100 {
stop 10.94.66.120
}
}
}
static-arp disable
use-dnsmasq disable
}
dns {
forwarding {
cache-size 150
listen-on eth1
listen-on switch0
}
}
gui {
http-port 80
https-port 443
older-ciphers enable
}
nat {
rule 5010 {
description "masquerade for WAN"
outbound-interface eth0
type masquerade
}
}
ssh {
port 22
protocol-version v2
}
}